New Forums are now up!

Greetings Dragon Lords! Please visit our new forums at! We're leaving this old forum up for a period of time to allow players to migrate over any important posts, but will eventually close them out. Please note that you will need to log in using your PocketID over on the new forum. You can also access them through the game by tapping on Settings > Forums!
See more
See less

New Update 2.30

  • Filter
  • Time
  • Show
Clear All
new posts

  • New Update 2.30

    Is there any way we can roll back off this shitty update. Game is constantly crashing enough that I can maybe get 1 attack in between 3-5 crashes. The warriors and sorcerers are pausing after you initiate a spell which in most cases leads to death. Pull the update and actually test this crap before sending it out to us. And an event is starting soon, hope this gets fixed or you won't have many players actually playing.

  • #2
    That's actually the one saving grace. Game doesn't work. No money can be made for an event.

    This will be fixed


    • #3
      Same here, doing the same thing to mine, why can't they just leave the game alone. They sure don't know how to fix it. They always do this rt before an event, if they did it Monday it could be fixed by now.


      • XDragonizer
        XDragonizer commented
        Editing a comment
        It's a shitty update for sure but they have no control over when it should be released. It's all up to Apple.

    • #4
      My understanding is that the crashing issue should no longer be occurring. If you're still having problems with it, please report it here:


      • #5
        CampusLifer sorry to inform you that crashes are still happening, as issues with attack pausing when you cast a spell, news messages that can't be read, and lots more I haven't experienced yet but habe been reported from team mates and friends.
        Let us roll back to previous version, I preferred earlier bugs, than new features that seemed nice while written, but led to having game pretty unplayable.


        • #6
          Maybe it's a device thing? I haven't had any issue other than a blank event email and warriors flames stop after using spells


          • DarkOsgiliath
            DarkOsgiliath commented
            Editing a comment
            YellowMonkey that ain't nothing. And it's not only about warriors. Also sorcerers and hunters have same glitch. We tested on couple dozen devices so far. Same thing on each one.
            This update introduces some pretty good enhancements but if the cost of having it unplayable or quite, well, I'd vot for rolling back to previous version.

          • YellowMonkey
            YellowMonkey commented
            Editing a comment
            DarkOsgiliath I understand. Was just asking, I can't give much feedback on the matter since I'm not have the same issues

        • #7
          When is this going to be fixed most frustrating..


          • #8
            We are working on the issues with the dragons having a hiccup in their normal attacks after using a spell. We hope have a hot fix released as quickly as possible.

            As a quick work around, you can take your finger off the screen when attacking with the normal attack, use the spell, and then tap and hold, swipe, or tap again (depending on the dragon) and you should be able to continue. I know it's not the best solution, but it's just a temporary workaround until we get the hot fix out


            • DDizzle
              DDizzle commented
              Editing a comment
              The attack bug isn't the worst but as CaptainC said below it just sucks. The bug of "No Connection..." That he mentioned is the most irritating but to me at the moment. Happens 4/5 runs for me. And I'm still crashing here and there. The connection issue just sucks cuz I know it's not true, at least. Ha he the message as its nothing to do with my connection, lol!

            • VixLin
              VixLin commented
              Editing a comment
              DDizzle Hey I'm getting that kind of message too! Except it's only when I try to join attack/defense invites when I get that message. Been going on for about 5 months now.

          • #9
            I keep getting this bug where I'm just about to start a run with a x5 multiplier and all of a sudden my wife calls me.

            Anyone else getting this? Seriously frustrating. Can you produce a hotfix for that too PG?
            The one place to find all you need to get better at War Dragons!


            • JSG
              JSG commented
              Editing a comment
              PG will arrange a divorce for enough cash.

            • Fairyknight
              Fairyknight commented
              Editing a comment
              Create an account for her, lure her in your guild give her enough RSS to keep growing, and soon you will sit together doing multis.

              One thing remains though who takes care of the kids? If you find a solution other than having none, let me know. The other thing worked for me :-)

          • #10
            Same problems here.
            Winners find solutions, losers find excuses.


            • #11
              On top of the other bugs, it takes forever to load the matchmaking screen and it times out 2 out of 3 times.

              And just lift your finger to use a spell, while your dragons die? We can figure that out but it sure sucks the fun out of trying to play.

              I hope you guys at least delay the event until the attack and loading bugs are fixed.
              What, me worry?


              • Lock471
                Lock471 commented
                Editing a comment
                Same problem here still cant attack ? loosing so much game time and cant even wing the wars ?

              • Oldmandragon
                Oldmandragon commented
                Editing a comment
                I found a work around. But I am having to do it every single time I log out and back in.

                Get someone else on your team to attack, hit invite.
                Join that attack and let them give you the kill.

                Then you'll be able to again attack normally and it also allows your book marks to start working.

                But again, I have to do this every time I log in. Or I can't attack.

                It's not a fix, but at least a way to work around it.

            • #12
              Extra one to add, my x5 multipliers didn't arrive. I've sent a help report in but we all know how useful that is.


              • #13
                Still cant attack the no internet connection keeps coming up when is this going to be Fixed ?


                • #14
                  Our guild is in the middle of 2 wars and we are being told to upgrade or we cant assist in attacks or defences. I upgraded and I'm still getting the same message with others being told the attacker needs to upgrade. It seems to be a lottery. It's not helping our war efforts.


                  • SilentOne
                    SilentOne commented
                    Editing a comment
                    One of the main issues around this is that if you update and your attacker doesn't you can't defend your own base. Probably works the other way as well, if you haven't updated and they have you can't defend either.

                    There should be something in place where an attacker can't attack a base unless they have the same version, that would be the best way to solve this update during wars issue. Then again I'm sure players would abuse this and not update so they then can't be attacked. lol

                • #15
                  One of my members hasn't got the update in his App Store yet. He tried to assist me in my attack and he was told that I had an older version and he had to remind me to upgrade. Yet I'm running the new update. It's all a little confusing.