Announcement

Collapse

New Forums are now up!

Greetings Dragon Lords! Please visit our new forums at http://forums.wardragons.com! We're leaving this old forum up for a period of time to allow players to migrate over any important posts, but will eventually close them out. Please note that you will need to log in using your PocketID over on the new forum. You can also access them through the game by tapping on Settings > Forums!
See more
See less

"Your device isn't compatible with this version."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Your device isn't compatible with this version."

    I have an s8 and it wont let me download the update. Any suggestions? Works fine on my tablet.

  • #2
    If you have your pocket gem account setup I think your best option is to uninstall and install from scratch. I have an older S7 and it works on that device.

    Mainly it is the 'no name brand' of android devices in particular tablets that are not compatible.

    Comment


    • #3
      I'm on s7 edge and I'm getting the same as OP states device is not compatible PGJared any clue what's going on?

      Comment


      • Marvin Lamb
        Marvin Lamb commented
        Editing a comment
        My s7 edge works fine....well, other chat taking stupid long to do anything.

    • #4
      I using an s8+ and the update works fine for me as of right now.

      Comment


      • #5
        Hi. Can you please post more info Frequincy ? Maybe a screenshot of the error message? One of our engineers is using a S7-edge and he claims it's working fine for him.

        Comment


        • #6
          One of our engineers asks me to ask you "can we get as much information about these devices as we can. e.g. which version of Android they are running"

          Comment


          • #7

            Comment


            • #8
              I'm on s7 edge android version 7.0

              Comment


              • #9
                One of our engineers asks me to ask you "Please provide model number. these devices have different models under the same name with very different hardware. for example, the S7 edge comes with a different GPU made by a different company depending on the version you get"

                Comment


                • #10
                  Model SM-G935T

                  Comment


                  • #11
                    Same error as Frequincy. Im using a Galaxy S8 (SM-G95OU) and Android version 7.0

                    Comment


                    • #12
                      Hi. The android team asks me to communicate the following things:
                      • Person #1 says: from what i found online. the user has to download the lastest version of the google play store
                      • Person #2 says: If you go to the play store in a full browser you can get more details on why Google Play won't let you install. You can click the message to see which device google play thinks you have. If that solution doesn’t work, maybe he has an older device linked to his google play account?

                      Comment


                      • #13
                        CampusLifer Seems like my Google Play is up to date. I'm a little confused with #2. But based on my PC browser it thinks my S8 is not compatible but my tablet is.

                        Comment


                        • #14
                          Same google play is up to date and only have 1 device on acct
                          Attached Files
                          Last edited by Frequincy; 08-30-2017, 06:01 PM.

                          Comment


                          • #15
                            CampusLifer would you like us to make a ticket with IGS

                            Comment

                            Working...
                            X